Jump to content
Web Marketing Help Forum
dwgaraln

Feedback

Recommended Posts

Hi dwgaraln,

A little slow loading here.

 

When I scrolled down (in IE8) your sections below Follow Us are off to the right (i.e. not in their containers). It is also broken in FF 4.

 

You need to fix the title tag for the home page. It is showing your url instead of the blog title.

Edited by WiseWebmaster

Share this post


Link to post
Share on other sites

 

When I scrolled down (in IE8) your sections below Follow Us are off to the right (i.e. not in their containers). It is also broken in FF 4.

 

 

I notice the same thing. As WiseWebmaster you need to change the title tag...

 

Also at the bottom there seems to be a lot of empty space, will that be filled up as you post more? If not you shoul move some elements around to give it a condensed look (hope that made sense!)

 

The site loaded pretty quickly for me though.

 

All the best!!

Share this post


Link to post
Share on other sites

overall, it's pretty good, but I personally will recommend to think about background changing, as it looks mixed up and not so catchy. Also while scrolling the featured articles an error had occurred. The images haven't displayed. The loading time is good, as well as website filling.

So, hope these two cents will help you to make qualitative improvements.

Share this post


Link to post
Share on other sites

The site loads properly now and looks much better.

But I get an error on the featured articles box at the top

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×